// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r": (.*?) ").unwrap();
let string = "Date: 03/03 - 14:10
text
And from
Date/Time: 08/03/16 13:50
Summary of Fault: ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}