re = /: (.*?) /
str = 'Date: 03/03 - 14:10
text
And from
Date/Time: 08/03/16 13:50
Summary of Fault: '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end