#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[#.][-_]?[_a-zA-Z]+(?:\w|\\.)*|(?<=\s+|^)(?:\w+|\*)|\[[^\s"'=<>`]+?(?<![~|^$*])([~|^$*]?=(?:['"].*['"]|[^\s"'=<>`]+))?\]|:[\w-]+(?:\(.*\))?"
Local $sString = ".class {}" & @CRLF & _
".class .class {}" & @CRLF & _
".class #id {}" & @CRLF & _
"tag #idtag {}" & @CRLF & _
"[attribute] {}" & @CRLF & _
"[attribute*="value"] {}" & @CRLF & _
"[attribute$=value] {}" & @CRLF & _
".class:not(.class) {}" & @CRLF & _
".clas\$s tag" & @CRLF & _
".class:nth-child(2n+8):nth-of-type(-n+15)" & @CRLF & _
"tag *"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")