using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[#.][-_]?[_a-zA-Z]+(?:\w|\\.)*|(?<=\s+|^)(?:\w+|\*)|\[[^\s""'=<>`]+?(?<![~|^$*])([~|^$*]?=(?:['""].*['""]|[^\s""'=<>`]+))?\]|:[\w-]+(?:\(.*\))?";
string input = @".class {}
.class .class {}
.class #id {}
tag #idtag {}
[attribute] {}
[attribute*=""value""] {}
[attribute$=value] {}
.class:not(.class) {}
.clas\$s tag
.class:nth-child(2n+8):nth-of-type(-n+15)
tag *";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}