import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[#.][-_]?[_a-zA-Z]+(?:\\w|\\\\.)*|(?<=\\s+|^)(?:\\w+|\\*)|\\[[^\\s\"'=<>`]+?(?<![~|^$*])([~|^$*]?=(?:['\"].*['\"]|[^\\s\"'=<>`]+))?\\]|:[\\w-]+(?:\\(.*\\))?";
final String string = ".class {}\n"
+ ".class .class {}\n"
+ ".class #id {}\n"
+ "tag #idtag {}\n"
+ "[attribute] {}\n"
+ "[attribute*=\"value\"] {}\n"
+ "[attribute$=value] {}\n"
+ ".class:not(.class) {}\n"
+ ".clas\\$s tag\n"
+ ".class:nth-child(2n+8):nth-of-type(-n+15)\n"
+ "tag *";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}