re = /[#.][-_]?[_a-zA-Z]+(?:\w|\\.)*|(?<=\s+|^)(?:\w+|\*)|\[[^\s"'=<>`]+?(?<![~|^$*])([~|^$*]?=(?:['"].*['"]|[^\s"'=<>`]+))?\]|:[\w-]+(?:\(.*\))?/m
str = '.class {}
.class .class {}
.class #id {}
tag #idtag {}
[attribute] {}
[attribute*="value"] {}
[attribute$=value] {}
.class:not(.class) {}
.clas\\$s tag
.class:nth-child(2n+8):nth-of-type(-n+15)
tag *'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end