const regex = /[#.][-_]?[_a-zA-Z]+(?:\w|\\.)*|(?<=\s+|^)(?:\w+|\*)|\[[^\s"'=<>`]+?(?<![~|^$*])([~|^$*]?=(?:['"].*['"]|[^\s"'=<>`]+))?\]|:[\w-]+(?:\(.*\))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[#.][-_]?[_a-zA-Z]+(?:\\w|\\\\.)*|(?<=\\s+|^)(?:\\w+|\\*)|\\[[^\\s"\'=<>`]+?(?<![~|^$*])([~|^$*]?=(?:[\'"].*[\'"]|[^\\s"\'=<>`]+))?\\]|:[\\w-]+(?:\\(.*\\))?', 'gm')
const str = `.class {}
.class .class {}
.class #id {}
tag #idtag {}
[attribute] {}
[attribute*="value"] {}
[attribute\$=value] {}
.class:not(.class) {}
.clas\\\$s tag
.class:nth-child(2n+8):nth-of-type(-n+15)
tag *`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}