package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`value=\"([\w]+)\"`)
var str = `<input type="hidden" name="csrfmiddlewaretoken" value="676248f0994e62274dea72023fe699ff">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}