$re = '/value=\"([\w]+)\"/';
$str = '<input type="hidden" name="csrfmiddlewaretoken" value="676248f0994e62274dea72023fe699ff">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);