import Foundation
let pattern = #"value=\"([\w]+)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<input type="hidden" name="csrfmiddlewaretoken" value="676248f0994e62274dea72023fe699ff">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}