// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"value=\"([\w]+)\""#).unwrap();
let string = "<input type=\"hidden\" name=\"csrfmiddlewaretoken\" value=\"676248f0994e62274dea72023fe699ff\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}