const regex = /value=\"([\w]+)\"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('value=\\"([\\w]+)\\"', '')
const str = `<input type="hidden" name="csrfmiddlewaretoken" value="676248f0994e62274dea72023fe699ff">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}