import re
regex = re.compile(r"value=\"([\w]+)\"")
test_str = "<input type=\"hidden\" name=\"csrfmiddlewaretoken\" value=\"676248f0994e62274dea72023fe699ff\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")