# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<span[ \t]+([^>"']|"[^"]*"|'[^']*'|\n)*(\bclass="foo")([^>"']|"[^"]*"|'[^']*'|\n)*>([^<]*)<\\/span>/$4/gm;t' <<< "This is a sample of <span class=\"bar\" class=\"foo\" class=\"foobar\">
Text included
inside one span tag of class \"foo\".
</span> This is the text after the span tag.
This is another <span class=\"bar\">span</span>, but it doesn't belong to class foo.
This is another <span class=\"foo\">span</span>, and it does belong to class foo."