import Foundation
let pattern = #"<span[ \t]+([^>"']|"[^"]*"|'[^']*'|\n)*(\bclass="foo")([^>"']|"[^"]*"|'[^']*'|\n)*>([^<]*)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is a sample of <span class="bar" class="foo" class="foobar">
Text included
inside one span tag of class "foo".
</span> This is the text after the span tag.
This is another <span class="bar">span</span>, but it doesn't belong to class foo.
This is another <span class="foo">span</span>, and it does belong to class foo.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)