#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<span[ \t]+([^>"']|"[^"]*"|'[^']*'|\n)*(\bclass="foo")([^>"']|"[^"]*"|'[^']*'|\n)*>([^<]*)<\/span>"
Local $sString = "This is a sample of <span class="bar" class="foo" class="foobar">" & @CRLF & _
"Text included" & @CRLF & _
"inside one span tag of class "foo"." & @CRLF & _
"</span> This is the text after the span tag." & @CRLF & _
"" & @CRLF & _
"This is another <span class="bar">span</span>, but it doesn't belong to class foo." & @CRLF & _
"" & @CRLF & _
"This is another <span class="foo">span</span>, and it does belong to class foo."
Local $sSubst = "$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)