$re = '/<span[ \t]+([^>"\']|"[^"]*"|\'[^\']*\'|\n)*(\bclass="foo")([^>"\']|"[^"]*"|\'[^\']*\'|\n)*>([^<]*)<\/span>/m';
$str = 'This is a sample of <span class="bar" class="foo" class="foobar">
Text included
inside one span tag of class "foo".
</span> This is the text after the span tag.
This is another <span class="bar">span</span>, but it doesn\'t belong to class foo.
This is another <span class="foo">span</span>, and it does belong to class foo.';
$subst = "$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;