package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<span[ \t]+([^>"']|"[^"]*"|'[^']*'|\n)*(\bclass="foo")([^>"']|"[^"]*"|'[^']*'|\n)*>([^<]*)<\/span>`)
var str = `This is a sample of <span class="bar" class="foo" class="foobar">
Text included
inside one span tag of class "foo".
</span> This is the text after the span tag.
This is another <span class="bar">span</span>, but it doesn't belong to class foo.
This is another <span class="foo">span</span>, and it does belong to class foo.`
var substitution = "$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}