use strict;
my $str = 'This is a sample of <span class="bar" class="foo" class="foobar">
Text included
inside one span tag of class "foo".
</span> This is the text after the span tag.
This is another <span class="bar">span</span>, but it doesn\'t belong to class foo.
This is another <span class="foo">span</span>, and it does belong to class foo.';
my $regex = qr/<span[ \t]+([^>"']|"[^"]*"|'[^']*'|\n)*(\bclass="foo")([^>"']|"[^"]*"|'[^']*'|\n)*>([^<]*)<\/span>/mp;
my $subst = '$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";