// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<span[ \t]+([^>"']|"[^"]*"|'[^']*'|\n)*(\bclass="foo")([^>"']|"[^"]*"|'[^']*'|\n)*>([^<]*)<\/span>"#).unwrap();
let string = "This is a sample of <span class=\"bar\" class=\"foo\" class=\"foobar\">
Text included
inside one span tag of class \"foo\".
</span> This is the text after the span tag.
This is another <span class=\"bar\">span</span>, but it doesn't belong to class foo.
This is another <span class=\"foo\">span</span>, and it does belong to class foo.";
let substitution = "$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}