package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?[=|;].*)`)
var str = `xxx OR 1=1
1 OR 1=1
XXXXX; DROP TABLE *
123 ; SELECT *
é só um nome
nome
123
4444
5555555
xxxx or 1=1
XXXXX; DROP TABLE *`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}