import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?[=|;].*)";
final String string = "xxx OR 1=1\n"
+ "1 OR 1=1\n"
+ "XXXXX; DROP TABLE *\n"
+ "123 ; SELECT *\n"
+ "é só um nome\n"
+ "nome\n"
+ "123\n"
+ "4444\n"
+ "5555555\n"
+ "xxxx or 1=1\n"
+ "XXXXX; DROP TABLE *";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}