$re = '/(.*?[=|;].*)/';
$str = 'xxx OR 1=1
1 OR 1=1
XXXXX; DROP TABLE *
123 ; SELECT *
é só um nome
nome
123
4444
5555555
xxxx or 1=1
XXXXX; DROP TABLE *';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);