// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*?[=|;].*)").unwrap();
let string = "xxx OR 1=1
1 OR 1=1
XXXXX; DROP TABLE *
123 ; SELECT *
é só um nome
nome
123
4444
5555555
xxxx or 1=1
XXXXX; DROP TABLE *";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}