import re
regex = re.compile(r"(.*?[=|;].*)")
test_str = ("xxx OR 1=1\n"
"1 OR 1=1\n"
"XXXXX; DROP TABLE *\n"
"123 ; SELECT *\n"
"é só um nome\n"
"nome\n"
"123\n"
"4444\n"
"5555555\n"
"xxxx or 1=1\n"
"XXXXX; DROP TABLE *")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")