import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]+) ([a-z]*) (.+)*$";
final String string = "Salix x sepulcralis 'Chrysocoma'\n"
+ "Aesculus x carnea\n"
+ "Prunus 'Accolade'\n"
+ "Acer campestre 'Elsrijk'\n"
+ "Abies alba\n"
+ "Betula utilis var. jacquemontii\n"
+ "Crataegus crus-galli\n"
+ "Crataegus laevigata 'Paul's Scarlet'\n"
+ "Ilex 'Nellie R. Stevens'\n"
+ "Sorbus x thuringiaca 'Fastigiata'\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}