$re = '/^([a-zA-Z]+) ([a-z]*) (.+)*$/m';
$str = 'Salix x sepulcralis \'Chrysocoma\'
Aesculus x carnea
Prunus \'Accolade\'
Acer campestre \'Elsrijk\'
Abies alba
Betula utilis var. jacquemontii
Crataegus crus-galli
Crataegus laevigata \'Paul\'s Scarlet\'
Ilex \'Nellie R. Stevens\'
Sorbus x thuringiaca \'Fastigiata\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);