// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z]+) ([a-z]*) (.+)*$").unwrap();
let string = "Salix x sepulcralis 'Chrysocoma'
Aesculus x carnea
Prunus 'Accolade'
Acer campestre 'Elsrijk'
Abies alba
Betula utilis var. jacquemontii
Crataegus crus-galli
Crataegus laevigata 'Paul's Scarlet'
Ilex 'Nellie R. Stevens'
Sorbus x thuringiaca 'Fastigiata'
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}