import Foundation
let pattern = #"^([a-zA-Z]+) ([a-z]*) (.+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Salix x sepulcralis 'Chrysocoma'
Aesculus x carnea
Prunus 'Accolade'
Acer campestre 'Elsrijk'
Abies alba
Betula utilis var. jacquemontii
Crataegus crus-galli
Crataegus laevigata 'Paul's Scarlet'
Ilex 'Nellie R. Stevens'
Sorbus x thuringiaca 'Fastigiata'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)