re = /^([a-zA-Z]+) ([a-z]*) (.+)*$/m
str = 'Salix x sepulcralis \'Chrysocoma\'
Aesculus x carnea
Prunus \'Accolade\'
Acer campestre \'Elsrijk\'
Abies alba
Betula utilis var. jacquemontii
Crataegus crus-galli
Crataegus laevigata \'Paul\'s Scarlet\'
Ilex \'Nellie R. Stevens\'
Sorbus x thuringiaca \'Fastigiata\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end