const regex = /,(\d+)\(([^)]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(\\d+)\\(([^)]+)\\)', 'gm')
const str = `,545(Users),66049(CONSOLE LOGON),11(Authenticated Users),4095(CurrentSession),66048(LOCAL)`;
const subst = `'\2',\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);