use strict;
my $str = ',545(Users),66049(CONSOLE LOGON),11(Authenticated Users),4095(CurrentSession),66048(LOCAL)';
my $regex = qr/,(\d+)\(([^)]+)\)/mp;
my $subst = '\'\\2\',\\1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";