import Foundation
let pattern = #",(\d+)\(([^)]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #",545(Users),66049(CONSOLE LOGON),11(Authenticated Users),4095(CurrentSession),66048(LOCAL)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'\2',\1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)