using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*[^\d\r\n](\d+)";
string substitution = @"\1";
string input = @"2^64
asdgaf1_hsg534
asdfh23_hsjd12
dgshg_jhfsd86
test
1
testing 1234 testing 1 test4
testing 1234 testing 123";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}