package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*[^\d\r\n](\d+)`)
var str = `2^64
asdgaf1_hsg534
asdfh23_hsjd12
dgshg_jhfsd86
test
1
testing 1234 testing 1 test4
testing 1234 testing 123`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}