#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<Root>[A-Za-z]:(?:\/|\\))(?P<Relative>(?:(?:[^<>:"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:"\/\\|?*\n]+)(?:\.(?:png|jpg|jpeg)))$"
Local $sString = "C:/directory/file.png" & @CRLF & _
"C:/dire ctory/file.png" & @CRLF & _
"C:/directory1/directory2/file.png" & @CRLF & _
"C:/directory1/directory2/directory3/file.png" & @CRLF & _
"C:\directory\file.png" & @CRLF & _
"C:\directory1\directory2\file.png" & @CRLF & _
"C:\directory1\directory2\directory3\file.png" & @CRLF & _
"" & @CRLF & _
"C:/directory/file.txt" & @CRLF & _
"/directory/file.png" & @CRLF & _
"C:/directory//file.png" & @CRLF & _
"C:/dir" & @CRLF & _
"ectory/file.png" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")