$re = '/^(?P<Root>[A-Za-z]:(?:\/|\\\\))(?P<Relative>(?:(?:[^<>:"\/\\\\|?*\n])+(?:\/|\\\\))+)(?P<File>(?:[^<>:"\/\\\\|?*\n]+)(?:\.(?:png|jpg|jpeg)))$/m';
$str = 'C:/directory/file.png
C:/dire ctory/file.png
C:/directory1/directory2/file.png
C:/directory1/directory2/directory3/file.png
C:\\directory\\file.png
C:\\directory1\\directory2\\file.png
C:\\directory1\\directory2\\directory3\\file.png
C:/directory/file.txt
/directory/file.png
C:/directory//file.png
C:/dir
ectory/file.png
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);