re = /^(?P<Root>[A-Za-z]:(?:\/|\\))(?P<Relative>(?:(?:[^<>:"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:"\/\\|?*\n]+)(?:\.(?:png|jpg|jpeg)))$/m
str = 'C:/directory/file.png
C:/dire ctory/file.png
C:/directory1/directory2/file.png
C:/directory1/directory2/directory3/file.png
C:\\directory\\file.png
C:\\directory1\\directory2\\file.png
C:\\directory1\\directory2\\directory3\\file.png
C:/directory/file.txt
/directory/file.png
C:/directory//file.png
C:/dir
ectory/file.png
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end