using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<Root>[A-Za-z]:(?:\/|\\))(?P<Relative>(?:(?:[^<>:""\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:""\/\\|?*\n]+)(?:\.(?:png|jpg|jpeg)))$";
string input = @"C:/directory/file.png
C:/dire ctory/file.png
C:/directory1/directory2/file.png
C:/directory1/directory2/directory3/file.png
C:\directory\file.png
C:\directory1\directory2\file.png
C:\directory1\directory2\directory3\file.png
C:/directory/file.txt
/directory/file.png
C:/directory//file.png
C:/dir
ectory/file.png
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}