import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<Root>[A-Za-z]:(?:\\/|\\\\))(?P<Relative>(?:(?:[^<>:\"\\/\\\\|?*\\n])+(?:\\/|\\\\))+)(?P<File>(?:[^<>:\"\\/\\\\|?*\\n]+)(?:\\.(?:png|jpg|jpeg)))$";
final String string = "C:/directory/file.png\n"
+ "C:/dire ctory/file.png\n"
+ "C:/directory1/directory2/file.png\n"
+ "C:/directory1/directory2/directory3/file.png\n"
+ "C:\\directory\\file.png\n"
+ "C:\\directory1\\directory2\\file.png\n"
+ "C:\\directory1\\directory2\\directory3\\file.png\n\n"
+ "C:/directory/file.txt\n"
+ "/directory/file.png\n"
+ "C:/directory//file.png\n"
+ "C:/dir\n"
+ "ectory/file.png\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}