// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?P<Root>[A-Za-z]:(?:\/|\\))(?P<Relative>(?:(?:[^<>:"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:"\/\\|?*\n]+)(?:\.(?:png|jpg|jpeg)))$"#).unwrap();
let string = "C:/directory/file.png
C:/dire ctory/file.png
C:/directory1/directory2/file.png
C:/directory1/directory2/directory3/file.png
C:\\directory\\file.png
C:\\directory1\\directory2\\file.png
C:\\directory1\\directory2\\directory3\\file.png
C:/directory/file.txt
/directory/file.png
C:/directory//file.png
C:/dir
ectory/file.png
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}