const regex = /^(?P<Root>[A-Za-z]:(?:\/|\\))(?P<Relative>(?:(?:[^<>:"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:"\/\\|?*\n]+)(?:\.(?:png|jpg|jpeg)))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<Root>[A-Za-z]:(?:\\\/|\\\\))(?P<Relative>(?:(?:[^<>:"\\\/\\\\|?*\\n])+(?:\\\/|\\\\))+)(?P<File>(?:[^<>:"\\\/\\\\|?*\\n]+)(?:\\.(?:png|jpg|jpeg)))$', 'gm')
const str = `C:/directory/file.png
C:/dire ctory/file.png
C:/directory1/directory2/file.png
C:/directory1/directory2/directory3/file.png
C:\\directory\\file.png
C:\\directory1\\directory2\\file.png
C:\\directory1\\directory2\\directory3\\file.png
C:/directory/file.txt
/directory/file.png
C:/directory//file.png
C:/dir
ectory/file.png
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}