#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\\\d{8}\|$)(?P<file_path>.*)\|(?P<suffix>.*)"
Local $sString = "C:\Photos\Selfies\1|" & @CRLF & _
"C:\HDPhotos\Landscapes\2|" & @CRLF & _
"C:\Filters\Pics\12345678|" & @CRLF & _
"C:\Filters\Pics2\00000000|" & @CRLF & _
"C:\Filters\Pics2\00000000|XAV7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")