using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\\\d{8}\|$)(?P<file_path>.*)\|(?P<suffix>.*)";
string input = @"C:\Photos\Selfies\1|
C:\HDPhotos\Landscapes\2|
C:\Filters\Pics\12345678|
C:\Filters\Pics2\00000000|
C:\Filters\Pics2\00000000|XAV7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}