$re = '/^(?!.*\\\\\d{8}\|$)(?P<file_path>.*)\|(?P<suffix>.*)/m';
$str = 'C:\\Photos\\Selfies\\1|
C:\\HDPhotos\\Landscapes\\2|
C:\\Filters\\Pics\\12345678|
C:\\Filters\\Pics2\\00000000|
C:\\Filters\\Pics2\\00000000|XAV7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);