const regex = new RegExp('^(?!.*\\\\\\d{8}\\|$)(?P<file_path>.*)\\|(?P<suffix>.*)', 'gm')
const str = `C:\\Photos\\Selfies\\1|
C:\\HDPhotos\\Landscapes\\2|
C:\\Filters\\Pics\\12345678|
C:\\Filters\\Pics2\\00000000|
C:\\Filters\\Pics2\\00000000|XAV7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}