re = /^(?!.*\\\d{8}\|$)(?P<file_path>.*)\|(?P<suffix>.*)/m
str = 'C:\\Photos\\Selfies\\1|
C:\\HDPhotos\\Landscapes\\2|
C:\\Filters\\Pics\\12345678|
C:\\Filters\\Pics2\\00000000|
C:\\Filters\\Pics2\\00000000|XAV7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end