import Foundation
let pattern = #"^(?!.*\\\d{8}\|$)(?P<file_path>.*)\|(?P<suffix>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C:\Photos\Selfies\1|
C:\HDPhotos\Landscapes\2|
C:\Filters\Pics\12345678|
C:\Filters\Pics2\00000000|
C:\Filters\Pics2\00000000|XAV7
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)