#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+?)[?=-](.+?)[?=-](.+?)[?=.](.+?$)"
Local $sString = "US-LegolandFlorida-ScreenLineup.csv" & @CRLF & _
"US-39148-Floor6_S1-Lineup.csv" & @CRLF & _
"US-39148-Floor6_S1-Disclaimers.csv" & @CRLF & _
"US-39148-S3-Lineup.csv" & @CRLF & _
"US-39148-S3-Disclaimers.csv" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")