const regex = /(.+?)[?=-](.+?)[?=-](.+?)[?=.](.+?$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?)[?=-](.+?)[?=-](.+?)[?=.](.+?$)', 'gm')
const str = `US-LegolandFlorida-ScreenLineup.csv
US-39148-Floor6_S1-Lineup.csv
US-39148-Floor6_S1-Disclaimers.csv
US-39148-S3-Lineup.csv
US-39148-S3-Disclaimers.csv
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}